团体天梯练习 L2-003 月饼

发布时间 2023-04-17 00:20:21作者: Amαdeus

L2-003 月饼

月饼是中国人在中秋佳节时吃的一种传统食品,不同地区有许多不同风味的月饼。现给定所有种类月饼的库存量、总售价、以及市场的最大需求量,请你计算可以获得的最大收益是多少。

注意:销售时允许取出一部分库存。样例给出的情形是这样的:假如我们有 3 种月饼,其库存量分别为 18、15、10 万吨,总售价分别为 75、72、45 亿元。如果市场的最大需求量只有 20 万吨,那么我们最大收益策略应该是卖出全部 15 万吨第 2 种月饼、以及 5 万吨第 3 种月饼,获得 72 + 45/2 = 94.5(亿元)。

输入格式:

每个输入包含一个测试用例。每个测试用例先给出一个不超过 1000 的正整数 N 表示月饼的种类数、以及不超过 500(以万吨为单位)的正整数 D 表示市场最大需求量。随后一行给出 N 个正数表示每种月饼的库存量(以万吨为单位);最后一行给出 N 个正数表示每种月饼的总售价(以亿元为单位)。数字间以空格分隔。

输出格式:

对每组测试用例,在一行中输出最大收益,以亿元为单位并精确到小数点后 2 位。

输入样例:

3 20
18 15 10
75 72 45

输出样例:

94.50


解题思路

非常简单的模拟题,根据题目贪心模拟即可,要点就是定义个结构体按照平均价格降序排序,没了。

/*   一切都是命运石之门的选择  El Psy Kongroo  */
#include<iostream>
#include<cstdio>
#include<cstring>
#include<string>
#include<algorithm>
#include<vector>
#include<queue>
#include<deque>
#include<stack>
#include<map>
#include<set>
#include<bitset>
#include<cmath>
#include<functional>
using namespace std;

typedef long long ll;
typedef unsigned long long ull;
typedef pair<int, int> pii;
typedef pair<int, pii> piii;
typedef pair<double, double> pdd;
typedef pair<string, pii> psi;
typedef __int128 int128;
#define PI acos(-1.0)
#define x first
#define y second
//int dx[4] = {1, -1, 0, 0};
//int dy[4] = {0, 0, 1, -1};
const int inf = 0x3f3f3f3f, mod = 1e9 + 7;

const int N = 1010;
struct node{
    double c, w, ave;
}a[N];
int n, d;
double res;

int main(){
    ios::sync_with_stdio(false);
    cin.tie(0), cout.tie(0);

    cin >> n >> d;
    for(int i = 1; i <= n; i ++ ) cin >> a[i].c;
    for(int i = 1; i <= n; i ++ ) cin >> a[i].w, a[i].ave = a[i].w / a[i].c;

    sort(a + 1, a + n + 1, [](node &x, node &y){
        return x.ave > y.ave;   //按照平均价格降序排序
    });
    
    int tmp = d;
    for(int i = 1; i <= n && tmp > 0; i ++ ){
        if(tmp >= a[i].c){
            res += a[i].w;
            tmp -= a[i].c;
        }else{   
            res += a[i].w * (tmp / a[i].c);
            tmp = 0;
        }
    }

    printf("%.2lf", res);

    return 0;
}